Page 1 of 1

Railing Moves With the Screen

PostPosted: Thu Aug 16, 2012 11:20 am
by Jessica
This issue is kind of difficult to explain, and pictures don't exactly help. I placed one of the larger railings in the upper right portion of the Biodome: You can actually see it in this video for the first minute or so. If I scroll to the left, the decoration gets "stuck" on the edge of the screen and moves across. However, it remains in its original position, and seems to run into a wall at its left-most corner where it becomes invisible.

Have I confused you enough? Like I said, I don't know quite how to describe it! I've taken a few pictures that I can gladly post, if they'll help. I haven't fully tested this issue to see if it's only the one railing that's affected, although it appears to be so. I also confirmed that it isn't the options panels that create the issue: When they're fully opened, the decoration still only reacts to the edge of the screen.

This might be more of a tweak than an annoyance, so feel free to downgrade it!

Re: Railing Moves With the Screen

PostPosted: Thu Aug 16, 2012 3:25 pm
by Amaikokonut
Wow, that sounds like an odd one. When you say it get stuck, do you mean it starts floating with the screen, like the way UI elements do? I tried putting a railing in the same place to attempt to replicate this, but with no luck. Do you remember anything else you might have done before it started acting that way? Maybe you could take a short video of it happening? Any more pictures/information would be quite helpful.

Thanks for the report either way. It sounds to me like a possible issue with the ATTR not changing correctly when the agent is locked into place, but I don't think I'll know until I can duplicate it myself.

Is anyone else having an issue like this?

Re: Railing Moves With the Screen

PostPosted: Thu Aug 16, 2012 9:10 pm
by Reed
I've also had an issue with this. Both with a railing and the c2 straw house. They were both on the far rights side of the screen and moved when I scrolled left. Also, it was like the image moved, but within the space the image originally was. It's hard to explain, but I can see if I can video it later, if that might help.

Re: Railing Moves With the Screen

PostPosted: Thu Aug 16, 2012 9:14 pm
by Jessica
That sounds exactly like what I'm experiencing, Reed! I'll be busy for the next couple of days, but if a video isn't posted by then, I'll be sure to post one, Amai! I think this is one case where a ten second video can say more than a million words!

Re: Railing Moves With the Screen

PostPosted: Fri Aug 17, 2012 5:46 pm
by Reed
I took some pictures. I couldn't recreate the bug with the railing, but it was still doing it with the house.
http://imgur.com/a/0dyqa
(Also they're not quite in the right order, sorry. I'm not used to using imgur).

Re: Railing Moves With the Screen

PostPosted: Sat Sep 01, 2012 10:00 pm
by Jessica
I apologize about the terrible delay! In my latest Creatures video, I highlighted this issue at about the 1:30 mark. There are only about 10-20 seconds of footage, but I hope this clarifies the issue a little better! Let me know if you need any other information, though. Like I say in the video, it's not something that really bothers me, but it would be nice to have it fixed in the next release. Thanks!

Re: Railing Moves With the Screen

PostPosted: Sun Sep 02, 2012 3:39 pm
by Amaikokonut
I did notice that in the video.... very strange. Considering it's graphics related I'm willing to bet it's not so much a caos-bug as perhaps an engine side effect of tinting and/or MIRA, which would put it frustratingly out of my control.

Maybe we could narrow it down a little though. Anyone experiencing this issue, would you please leave as many details about your setup as possible, including, what version of DS you're running (Standalone, Exodus, GOG Exodus, etc) as well as the OS you're running it on? Also if you notice this happening again, could you note if the decoration has been tinted and/or mirrored?

Also, just to rule out other causes, note the metaroom this is happening in if possible (specifically, have any of you noticed the bug happening outside of the biodome?)

Thanks for the feedback guys :>

Re: Railing Moves With the Screen

PostPosted: Sat Sep 15, 2012 5:52 pm
by Grendel Man
I managed to replicate this bug in my own world by first tinting the decoration, then flipping it around. Just flipping the decoration won't cause the bug, and neither will just tinting the decoration. I also found that it happens regardless which side of the screen the decoration hits - if it hits the left side, it'll scroll with that side of the screen, and vice-versa.

I'm running the standalone DS on a Windows 7 64-bit OS. I initially tested this in the Biodome, but it's not metaroom specific - I tested it in the Meso shortly afterwards, and the same thing happened.

Edit: After some more testing, I can confirm that this is not an issue with the Garden Box - it's an issue with the game itself. Applying both the "tint" command and the "mira" command to an object will make its sprite behave this way as well, regardless of what it is (for example, Trix's Vampyre Castle toy).

Edit2: For further confirmation that this has nothing to do with the Garden Box...here's a picture of the bug in Creatures 3 standalone.